Subject: Ltmodem still freezing
From: phlustik@uchicago.edu
Date: Mon, 5 Feb 2001 19:55:30 -0600

Hello,

I am still having occasional freeze-ups with ltmodem, even after upgrade to
5.78d. This is on Debian 2.2.17 generic kernel and Toshiba Satellite 2545.

I've found the freeze to happen under a few specific conditions: FTPing a
file with overwrite or sending a message over IMAP.

The tcpdump for ppp0 contains nothing obvious (to me), the log shows
failure to receive responses to echo requests:

Jan 31 09:28:27 bambi pppd[29990]: sent [LCP EchoReq id=0x53 magic=0xc3ecab5b]
Jan 31 09:28:27 bambi pppd[29990]: rcvd [LCP EchoRep id=0x53 magic=0x9f7f25a9]
Jan 31 09:28:57 bambi pppd[29990]: sent [LCP EchoReq id=0x54 magic=0xc3ecab5b]
Jan 31 09:29:27 bambi pppd[29990]: sent [LCP EchoReq id=0x55 magic=0xc3ecab5b]
Jan 31 09:29:57 bambi pppd[29990]: sent [LCP EchoReq id=0x56 magic=0xc3ecab5b]
Jan 31 09:30:27 bambi pppd[29990]: sent [LCP EchoReq id=0x57 magic=0xc3ecab5b]
Jan 31 09:30:57 bambi pppd[29990]: No response to 4 echo-requests
Jan 31 09:30:57 bambi pppd[29990]: Serial link appears to be disconnected.

At the same time the connection freezes, something (pppd?) removes the
group write permission on ttLT0:

bambi:/home/petr# ll /dev/ttyLT0 
crw-r--r--    1 root     uucp      62,  64 Jan 30 10:51 /dev/ttyLT0

Bizarre, isn't it? I can send the tcpdump for inspection upon request. I
upgraded ppp to 2.4.0f with no help. This is the modem PCI entry:

bambi:/home/petr# lspci -v
00:07.0 Communication controller: Lucent Microelectronics 56k WinModem (rev 01)
        Subsystem: Toshiba America Info Systems Internal V.90 Modem
        Flags: bus master, medium devsel, latency 0, IRQ 3
        Memory at ffefff00 (32-bit, non-prefetchable)
        I/O ports at 02f8
        I/O ports at 1c00
        Capabilities: [f8] Power Management version 2

Thanks for any clues.

Best,
Petr